Linux PyQt tray application to control OctoPrint instances
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

PKGBUILD 664B

1234567891011121314151617181920212223
  1. # Maintainer: Thomas Buck <thomas@xythobuz.de>
  2. pkgname=OctoTray
  3. pkgver=0.5
  4. pkgrel=1
  5. pkgdesc="Control OctoPrint/Moonraker instances from system tray"
  6. arch=('any')
  7. license=('unknown')
  8. depends=('python-pyqt5')
  9. source=("octotray"
  10. "octotray_icon.png"
  11. "de.xythobuz.octotray.desktop")
  12. md5sums=(SKIP
  13. SKIP
  14. SKIP)
  15. package() {
  16. mkdir -p "$pkgdir/usr/bin"
  17. cp octotray "$pkgdir/usr/bin/octotray"
  18. mkdir -p "$pkgdir/usr/share/pixmaps"
  19. cp octotray_icon.png "$pkgdir/usr/share/pixmaps/octotray_icon.png"
  20. mkdir -p "$pkgdir/usr/share/applications"
  21. cp de.xythobuz.octotray.desktop "$pkgdir/usr/share/applications/de.xythobuz.octotray.desktop"
  22. }