Browse Source

Removed MXS-Bootlet stuff, no longer needed

Thomas Buck 8 years ago
parent
commit
962a0c9e55
1 changed files with 0 additions and 122 deletions
  1. 0
    122
      board/olinuxino/mxs-bootlets/mxs-bootlets-01-olinuxino.patch

+ 0
- 122
board/olinuxino/mxs-bootlets/mxs-bootlets-01-olinuxino.patch View File

@@ -1,122 +0,0 @@
1
-Forward-ported patch from https://github.com/koliqi/imx23-olinuxino
2
-for mxs-bootlets-10.12.01
3
-
4
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
5
-
6
-diff -Nura imx-bootlets-src-10.12.01/linux_prep/board/imx23_olinuxino_dev.c imx-bootlets-src-10.12.01-olinuxino/linux_prep/board/imx23_olinuxino_dev.c
7
---- imx-bootlets-src-10.12.01/linux_prep/board/imx23_olinuxino_dev.c	1969-12-31 21:00:00.000000000 -0300
8
-+++ imx-bootlets-src-10.12.01-olinuxino/linux_prep/board/imx23_olinuxino_dev.c	2013-05-17 15:07:33.282961551 -0300
9
-@@ -0,0 +1,54 @@
10
-+/*
11
-+ * Platform specific data for the IMX23_OLINUXINO development board
12
-+ *
13
-+ * Fadil Berisha <fadil.r.berisha@gmail.com>
14
-+ *
15
-+ * Copyright 2008 SigmaTel, Inc
16
-+ * Copyright 2008 Embedded Alley Solutions, Inc
17
-+ * Copyright 2009-2010 Freescale Semiconductor, Inc. All Rights Reserved.
18
-+ *
19
-+ * This file is licensed under the terms of the GNU General Public License
20
-+ * version 2. This program is licensed "as is" without any warranty of any
21
-+ * kind, whether express or implied.
22
-+ *
23
-+ * http://www.opensource.org/licenses/gpl-license.html
24
-+ * http://www.gnu.org/copyleft/gpl.html
25
-+ */
26
-+#include <setup.h>
27
-+#include <keys.h>
28
-+#include <lradc_buttons.h>
29
-+
30
-+/************************************************
31
-+ * LRADC keyboard data *
32
-+ ************************************************/
33
-+int lradc_keypad_ch = LRADC_CH0;
34
-+int lradc_vddio_ch = LRADC_CH6;
35
-+
36
-+struct lradc_keycode lradc_keycodes[] = {
37
-+ { 100, KEY4 },
38
-+ { 306, KEY5 },
39
-+ { 601, KEY6 },
40
-+ { 932, KEY7 },
41
-+ { 1260, KEY8 },
42
-+ { 1424, KEY9 },
43
-+ { 1707, KEY10 },
44
-+ { 2207, KEY11 },
45
-+ { 2525, KEY12 },
46
-+ { 2831, KEY13 },
47
-+ { 3134, KEY14 },
48
-+ { -1, 0 },
49
-+};
50
-+
51
-+/************************************************
52
-+ * Magic key combinations for Armadillo *
53
-+ ************************************************/
54
-+u32 magic_keys[MAGIC_KEY_NR] = {
55
-+ [MAGIC_KEY1] = KEY4,
56
-+ [MAGIC_KEY2] = KEY6,
57
-+ [MAGIC_KEY3] = KEY10,
58
-+};
59
-+
60
-+/************************************************
61
-+ * Default command line *
62
-+ ************************************************/
63
-+char cmdline_def[] = "console=ttyAMA0,115200";
64
-diff -Nura imx-bootlets-src-10.12.01/linux_prep/cmdlines/imx23_olinuxino_dev.txt imx-bootlets-src-10.12.01-olinuxino/linux_prep/cmdlines/imx23_olinuxino_dev.txt
65
---- imx-bootlets-src-10.12.01/linux_prep/cmdlines/imx23_olinuxino_dev.txt	1969-12-31 21:00:00.000000000 -0300
66
-+++ imx-bootlets-src-10.12.01-olinuxino/linux_prep/cmdlines/imx23_olinuxino_dev.txt	2013-05-17 15:07:49.663496106 -0300
67
-@@ -0,0 +1,3 @@
68
-+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait
69
-+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait
70
-+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait
71
-diff -Nura imx-bootlets-src-10.12.01/linux_prep/core/setup.c imx-bootlets-src-10.12.01-olinuxino/linux_prep/core/setup.c
72
---- imx-bootlets-src-10.12.01/linux_prep/core/setup.c	2010-11-04 04:35:38.000000000 -0300
73
-+++ imx-bootlets-src-10.12.01-olinuxino/linux_prep/core/setup.c	2013-05-17 15:08:39.246114205 -0300
74
-@@ -84,6 +84,8 @@
75
- #include "../../mach-mx28/includes/registers/regsrtc.h"
76
- #elif defined(STMP378X)
77
- #include "../../mach-mx23/includes/registers/regsrtc.h"
78
-+#elif defined(IMX23_OLINUXINO)
79
-+#include "../../mach-mx23/includes/registers/regsrtc.h"
80
- #endif
81
-
82
- #define NAND_SECONDARY_BOOT          0x00000002
83
-diff -Nura imx-bootlets-src-10.12.01/linux_prep/include/mx23/platform.h imx-bootlets-src-10.12.01-olinuxino/linux_prep/include/mx23/platform.h
84
---- imx-bootlets-src-10.12.01/linux_prep/include/mx23/platform.h	2010-11-04 04:35:38.000000000 -0300
85
-+++ imx-bootlets-src-10.12.01-olinuxino/linux_prep/include/mx23/platform.h	2013-05-17 15:09:21.006476997 -0300
86
-@@ -19,6 +19,8 @@
87
-
88
- #if defined (BOARD_STMP378X_DEV)
89
- #define	MACHINE_ID	0xa45
90
-+#elif defined (BOARD_IMX23_OLINUXINO_DEV)
91
-+#define MACHINE_ID	0x1009
92
- #else
93
- #error "Allocate a machine ID for your board"
94
- #endif
95
-diff -Nura imx-bootlets-src-10.12.01/linux_prep/Makefile imx-bootlets-src-10.12.01-olinuxino/linux_prep/Makefile
96
---- imx-bootlets-src-10.12.01/linux_prep/Makefile	2010-11-04 04:35:38.000000000 -0300
97
-+++ imx-bootlets-src-10.12.01-olinuxino/linux_prep/Makefile	2013-05-17 15:09:53.554539143 -0300
98
-@@ -69,6 +69,11 @@
99
- HW_OBJS = $(LRADC_OBJS)
100
- CFLAGS += -DMX28 -DBOARD_MX28_EVK
101
- endif
102
-+ifeq ($(BOARD), imx23_olinuxino_dev)
103
-+ARCH = mx23
104
-+HW_OBJS = $(LRADC_OBJS)
105
-+CFLAGS += -DIMX23_OLINUXINO -DBOARD_IMX23_OLINUXINO_DEV
106
-+endif
107
-
108
- # Generic code
109
- CORE_OBJS = entry.o resume.o cmdlines.o setup.o keys.o
110
-diff -Nura imx-bootlets-src-10.12.01/Makefile imx-bootlets-src-10.12.01-olinuxino/Makefile
111
---- imx-bootlets-src-10.12.01/Makefile	2010-11-04 04:35:38.000000000 -0300
112
-+++ imx-bootlets-src-10.12.01-olinuxino/Makefile	2013-05-17 15:23:53.709956619 -0300
113
-@@ -16,6 +16,9 @@
114
- ifeq ($(BOARD), iMX28_EVK)
115
- ARCH = mx28
116
- endif
117
-+ifeq ($(BOARD), imx23_olinuxino_dev)
118
-+ARCH = mx23
119
-+endif
120
-
121
- all: build_prep gen_bootstream
122
-

Loading…
Cancel
Save